MAGEEWP

Themes for WordPress

MAGEEWP

Themes for WordPress

Homepage Forums WordPress Themes Support Cannot get One Page Menu to appear in Peony Page Options Drop Down Menu Box

Tagged: 

This topic contains 2 replies, has 2 voices, and was last updated by  Magee 5 months, 4 weeks ago.

  • Author
    Posts
  • #56804

    TRICIASBRANDS
    Participant
    • Topics: 3
    • Replies: 1
    • Total posts: 4

    HI. Having followed instructions on how to set up a One Page Menu in Appearance/Menu’s I then went into my Peony page (home page) and followed the Manual instructions for selecting my new menu…but alas it is not there. I have done a few WordPress sites and am at a loss as to why. Tried purging the cache and all the usual stuff but still no drop down menu appears, it’s like I did not create it but when I go back in Customisation for the Appearance settings, there it is! Could it be my anchors are wrong so it’s not appearing? I put the anchor names e.g. #Services in the slug field in the Peony page editing area.

  • #56853

    TRICIASBRANDS
    Participant
    • Topics: 3
    • Replies: 1
    • Total posts: 4

    OK so now I’ve got the menu to appear on the homepage, thanks to a little bit of a step missing from the manual to do with the “menu settings’ but the menu doesn’t jump to the anchor point. I think the problem is translation as the English is a little bit awkward? Can anyone please give me the exact steps for addint an anchor to the homepage section so the menu can reference it? I’ve got the URl as #services, the nav name as services, on the homepage section the slug is services, the title is services and I also put the Section extra classes name as “#services” in the hope that’d help. Nothing seems to work. Even tried http://www.companyname.com.au/#services as the URL but that doesn’t work either!

  • #56902

    Magee
    Keymaster
    • Topics: 30
    • Replies: 1857
    • Total posts: 1887

    Sorry but I can’t open your site. Please check.
    You only need to set section slug as “services”, then add menu item with url “#services” in your menu.

You must be logged in to reply to this topic.